Trabajando con diferentes versiones de Grails

En OSOCO hace tiempo que apostamos por Grails como framework para desarrollar aplicaciones web, y es la herramienta que elegimos por defecto en todos los proyectos nuevos de esta índole.

Con el tiempo, esto ha ocasionado que tengamos que trabajar con diferentes versiones de Grails a la vez, lo que por defecto puede ser algo engorroso.

Hace poco subí a mi GitHub un script que se encarga de lidiar con este problema. Sé que había cosas ya hechas para esto, pero me gusta cocinarme estas pequeñeces yo mismo :-), así que he subido el script al GitHub de OSOCO para quien lo encuentre útil:

Grails Multiple Versions

No tiene ningún misterio, pero ahorra tiempo :-D. Para hacerlo funcionar, basta con ponerlo en el path con mayor prioridad que la instalación de Grails (yo suelo tener estas cosas en $HOME/bin o $HOME/bin/scripts, que está al principio de mi path).

Se pueden configurar un par de variables (el nombre de la instalación por defecto y en qué directorios se buscarán tanto esa instalación como cualquier otra), pero con los valores por defecto debería funcionarle a la mayoría de la gente :-).

En cualquier caso, podéis ver una descripción de uso más detallada en el README.